Sopcast su Ubuntu 9.04 e 9.10

22 10 2009

ccc

Finalmente anche su Ubuntu possiamo vedere le nostre amate partite tramite sopcast, e non è cosa da poco. Personalmente mi scocciava il fatto che ogni volta dovevo entrare su win. no no no… Finalmente grazie all’aiuto del forum ora sopcast è realtà. L’installazione è molto semplice, ecco qua come:

ATTENZIONE: Su Ubuntu 9.10 ce un problema di dipendenze con la libreria libstdc++5 essendo che Karmic usa ++6. La soluzione è quella di scaricare ++5 di Jaunty e installarlo su Karmic. Andate QUI scegliete quello per la vostra architettura i386  per 32bit. Da li in poi potete seguire la guida senza nessun problema.

Per i 64bit mi è stato segnalato da “LoSufo”, che ringrazio, che la procedura è un altra, cioè questa qua: Su architetture amd64, il file libstdc++5 da installare è quello per architetture 32 bit. Dal deb vanno estratti i file libstdc++.so.5.0.7 e libstdc++.so.5 nella directory /usr/lib32, altrimenti on va.

1. Scaricare e installare con un doppio clic sp-auth da  QUI

2. Scaricare e installare con un doppio clic sopcast-player da QUI

3. Aprire una scheda di Firefox ed eseguire queste operazioni (vi consiglio di copiare le operazioni di questo passaggio su un editore di testo)

-Digitare   about:config nella barra degli indirizzi

-Clic destro -> New -> Boolean
-Digitare    network.protocol-handler.external.sop
-Impostare il valore a   true

-Clic destro -> New -> String
-Digitare       network.protocol-handler.app.sop
-Inserire il precorso dello script   /usr/bin/sopcast-player

4. Riavviare Firefox. La prima volta che aprite un link SOPCAST vi verrà fuori una finestra di Firefox – fare Sfoglia – andate su /usr/bin/sopcast-player
5. Solo quando avete verificato che tutto funziona, al prossimo link di sopcast che aprite spuntate “Ricorda Questa Azione”

EDIT: Per ora ce un piccolo BUG, quando si apre sopcast vengono fuori due finestre video, ma vi basta minimizzare uno o allargare una delle due. Oppure ce un altra soluzione, andate su Modifica – Preferenze – spuntate USA UN PLAYER ESTERNO, li di default ce mplayer io ho messo VLC (perche sono innamorato di lui) Con la nuova versione di sopcast-player questo BUG non ce più (per fortuna)

Link ubuntu-forum

Segnalo QUESTO link per gli amanti dei repository, vi basterà aggiungere il repo di cui si parla nel articolo e poi installare i due pacchetti semplicemente dal terminale

Annunci

Azioni

Information

9 responses

22 10 2009
Giuseppe

Questa guida di Ubuntu Italia andrebbe aggiornata -> http://wiki.ubuntu-it.org/Multimedia/Streaming/Gsopcast
Proprio con quanto hai scritto qui e ripreso egregiamente nel forum.
A te la parola (e l’azione).
Ciao, Giuseppe (aka as-far-as-i-know)

29 10 2009
LoSfuso

Su architetture amd64, il file libstdc++5 da installare è quello per architetture 32 bit. Dal deb vanno estratti i file libstdc++.so.5.0.7 e libstdc++.so.5 nella directory /usr/lib32, altrimenti on va

29 10 2009
tediket

Grazie per la segnalazione, non avendo il 64bit pensavo che bastasse installare il .deb per 64. Modifico la guida.. Ciao

29 10 2009
Ingalex

Guidoc vedi che il problema delle 2 finestre si verifica solo se si usa vlc, se invece si mette il segno di spunta su “usa player esterno” e si usa mplayer il problema non si verifica.
Poi volevo avvisarti che ho ricompilato sopcast-player e sp-auth inglobando in sopcast-player la libreria mancante e eliminando dalle dipendenze di entrambi i pacchetti libstdc++5.
Trovi tutto scritto qui: http://www.sourceslist.eu/installare-software-tramite-repository/installare-sopcast-player-0-3-0-su-ubuntu-karmic-koala-9-10-in-pochi-click/
I due pacchetti li ho inseriti nei miei repository.
Ciao Alex

29 10 2009
Ingalex

Ora creo anche il pacchetto per i 64 bit e lo inserisco.

29 10 2009
tediket

Fini li ci ero arrivato, nel senso se usi un player esterno allora hai solo uno,ok. Io intendevo di avere sopcast in un unica finestra come è sul windows per esempio. Quella di metterli in repo è una buona idea (sopratutto per i pigri :D)
Come hai risolto il problema di dipendenza della libstdc++5 ?

29 10 2009
Ingalex

ho inglobato i file libstdc++5 nel debian sopcast-player e ho eliminato la dipendenza sia da sopcast-player che da sp-auth. Ho lasciato ovviamente la dipendenza di sopcast-player da sp-auth.
Però voglio vedere se si riesce ad adattare sopcast-player con la nuova libreria libstdc++6. Magari creando un semplice link simbolico e cambiando le dipendenze.

29 10 2009
tediket

Capito cos’hai fatto. per la ++6 mi sa che bisogna leggere i sorgenti.. mi metto a leggere un po anch’io…

29 10 2009
Ingalex

secondo me basta cambiare i riferimenti ai singoli file e dovrebbe funzionare.

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...




%d blogger hanno fatto clic su Mi Piace per questo: